WordPress 更新频率是非常高的,每次省级都有新功能,也存在很多兼容性问题,假如你没有更新 WordPress 到最新版本,有些时候插件作者没有对旧版本的兼容,直接使用了新版本的函数,甚至会出现致命错误,让网站陷入瘫痪状态···当然你也可以在后台查看官方弹出的插件兼容性···

这篇教程中我将介绍 Better Plugin Compatibility Control 插件如何有效检测 WordPress 插件是否兼容当前的 WordPress 版本···

How to improve the compatibility of WordPress plugin 01

当有鼠标拖动至上面就会显示不兼容的警告信息···

How to improve the compatibility of WordPress plugin 02

插件不兼容的问题?
有些时候 WordPress 做到了极致,在更新新版本会主动做向下兼容,不会因为插件调用过时的函数而出现致命错误,如果出错大家可以找个能替代的插件,或者把 WordPress 降级并放弃使用插件,自己权衡···